Description:There is a board with 100 * 100 grids as shown below. The left-top gird is denoted as (1, 1) and the right-bottom grid is (100, 100).

img

We may apply three commands to the board:

1
2
3
4
5
6
7
8
9
10
1.    WHITE  x, y, L     // Paint a white square on the board, 
// the square is defined by left-top grid (x, y)
// and right-bottom grid (x+L-1, y+L-1)

2. BLACK x, y, L // Paint a black square on the board,
// the square is defined by left-top grid (x, y)
// and right-bottom grid (x+L-1, y+L-1)

3. TEST x, y, L // Ask for the number of black grids
// in the square (x, y)- (x+L-1, y+L-1)

In the beginning, all the grids on the board are white. We apply a series of commands to the board. Your task is to write a program to give the numbers of black grids within a required region when a TEST command is applied.

Input

The first line of the input is an integer t (1 <= t <= 100), representing the number of commands. In each of the following lines, there is a command. Assume all the commands are legal which means that they won’t try to paint/test the grids outside the board.

Output

For each TEST command, print a line with the number of black grids in the required region.

Sample Input

1
2
3
4
5
6
5
BLACK 1 1 2
BLACK 2 2 2
TEST 1 1 3
WHITE 2 1 1
TEST 1 1 3

Sample Output

1
2
7
6

这道题乍一看有点复杂,但是模拟一下就很简单了。棋盘初始全白,然后根据规则涂黑或者涂白。最后计算涂黑的个数就好了。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
#include<iostream>
#include<sstream>
#include<vector>
using namespace std;

int visits[101][101]={0};
const int N=100;
int cnt=0;

void split(const string& s, vector<string>& sv,const char sep=' ') {
sv.clear();
istringstream iss(s);
string tmp;

while(getline(iss, tmp,sep)) {
sv.push_back(tmp);
}
return;
}

void coloring(string line) {
if(line.size()==0)
return ;
vector<string> vec;
split(line, vec,' ');
string action=vec[0];
int x=atoi(vec[1].c_str());
int y=atoi(vec[2].c_str());
int step=atoi(vec[3].c_str());

if(action=="TEST"){
cnt=0;
for(int i=x;i<=x+step-1;i++){
for(int j=y;j<=y+step-1;j++){
if(visits[i][j]==1)
cnt+=1;
}
}
cout<<cnt<<endl;
}

for(int i=x;i<=x+step-1;i++) {
for(int j=y;j<=y+step-1;j++){
if(action=="BLACK"){
if(visits[i][j]==0){
visits[i][j]=1;
}
}else if(action=="WHITE"){
if(visits[i][j]==1){
visits[i][j]=0;
}
}
}
}
}

int main(){
int n;
while(cin>>n) {
string line;
getline(cin, line); // 这行是为了读取cin>>n的结束符
for(int i=0;i<n;i++){
getline(cin, line);
coloring(line);
}
}
return 0;
}